Mensagem de erro “A template was not provided” no npx create-react-app

Você se deparou com esse erro ao rodar o comando create-react-app?

A template was not provided. This is likely because you’re using an outdated version of create-react-app.
Please note that global installs of create-react-app are no longer supported.

Para resolver esse erro no Windows eu rodei este comando no console:

where create-react-app 

O resultado desse comando me indicou que o create-react-app estava instalado globalmente como módulo do yarn.

Depois rodei o comando:

yarn global remove create-react-app

Após esses passos, rodei o comando npx create-react-app e a mensagem não apareceu mais.

Fontes:

https://stackoverflow.com/questions/59188624/template-not-provided-using-create-react-app

https://stackoverflow.com/questions/304319/is-there-an-equivalent-of-which-on-the-windows-command-line